【Linux mint】sudo apt updateで「署名照合中にエラーが発生しました。リポジトリは更新されず、過去のインデックスファイルが使われます。GPG エラー:」が発生したときの対応方法

IT

この記事は備忘録です。

以前、brave-browswerをアンインストールしました($ sudo apt remove brave-browser)

そのあと、 「$ sudo apt update」すると、以下が発生

W: 署名照合中にエラーが発生しました。リポジトリは更新されず、過去のインデックスファイルが使われます。GPG エラー: https://brave-browser-apt-release.s3.brave.com stable InRelease: 公開鍵を利用できないため、以下の署名は検証できませんでした: NO_PUBKEY XXXXXXXXXXXXXXXX
W: https://brave-browser-apt-release.s3.brave.com/dists/stable/InRelease の取得に失敗しました  公開鍵を利用できないため、以下の署名は検証できませんでした: NO_PUBKEY XXXXXXXXXXXXXXXX
W: いくつかのインデックスファイルのダウンロードに失敗しました。これらは無視されるか、古いものが代わりに使われます。

原因は「gpg?」の削除ができてない。

そこで下記を入力したら解決した。

※これは公式サイトを参照した(URL

$ sudo rm /etc/apt/sources.list.d/brave-browser-*.list

コメント